Background and themes for widget in older Firefox

embeddedtimeline

#1

Have some embedded devices with older versions of firefox (<= 26) where the widget shows up nicely, but the background, no matter what theme you choose, remains pure black. Setting option transparent, with or without a theme specified results in same unchangeable blackness… Updating to the latest version of FF is not trivial on these embedded ARM devices with customized linux.

Assuming there’s some CSS that the widgets use that the older version of FF doesn’t support, is there a way to override the CSS so that we can force the background of that widget/generated iframe to be transparent?

I’ve searched these forums, and Google, but no one is reporting this behavior.


#2

I was unable to reproduce what you’re describing in FF25 on my Mac as both the theme and the transparent option worked as expected. Looking at how these options are implemented, they should be fully supported in older FF versions.

Can you share a screenshot of the problem? That may help me to diagnose the problem.


#3

Here are some screenshots, also My Bad — this is all FF 24-ish, not 25:

And you can see on this particular device its “Nightly” – which is the FF port for ARM devices. The link for the widget is [here][1]

I’ve tried it on the our intel platform on FF with the same results. Chrome, however, displays it correctly. Here are the screenshots (oops only allowed to post 2 images as a newbie):

You can see how it should be transparent, and is in Chrome on the intel device, with the code from the widget call on the twitter.html link included.
[1]: http://www.choice-media.ca/twitter.html


#4

Here’s the Chrome SS from the Intel device.


#5

I’ve definitely narrowed it down to Linux only. Here’s a screenshot of FFportable 24 on windows, with the Style editor open and only having changed the .Sandbox class background to yellow.

And here is the linux version with the same style edited on the fly:

I tried cutting out virtually ALL the generated style and applying background-color: #FFF to every element at a higher level than the body of the iframe, and nothing. Totally stumped…


#6

Sigh. I just tried it on another machine I have here running Fedora 20 with FF portable 24. Shows background just fine… Might as well close this - its obviously a problem that needs to be solved from within Puppy Linux.

Thanks for the attention.


#7