Avatars showing up in my profile widget even though they are set to "false"


#1

This afternoon, avatars began to appear in my profile widget even though avatars are set to false in the code. What’s going on? Could Twitter fix this ASAP?


Ah yes, the oscillating state of the display of avatars in embedded timelines
#2

We just pushed updates to our Search & Lists widgets today that display avatars regardless of your configuration options. This brings the widgets (and your in turn, your site) in line with our Display Guidelines.


#3

The problem is my profile widget has only a very narrow space to fit into in my Web site, so avatars take up too much space and make it difficult to read the tweets. Could you please restore the option of not showing avatars?


#4

This seems rather stupid when it’s used as a profile widget.

On my webpage I have a “My latest tweets”-widget… which is MY last tweets, so why show my picture and username everytime? I hope CSS workarounds will help / be allowed. If not, then I might as well stop using that widget.


#5

(Similar to the comment above) I have a profile widget embedded on a clients website.
This widget is configured to only shows their tweets.
Showing the avatar on every single tweet just doesn’t look right (and takes up too much space).

Also, is it me or do these changes now include showing the username before each tweet (I’m sure that wasn’t there before)?

Is there any chance twitter will reconsider these alterations (or at least allow users to not show them)?

Sorry but the phrase “if it ain’t broke, don’t fix it” springs to mind.


#6

In response to what Simon said above, yes, the user name gets featured together with the avatar before each tweet. While I re-tweet from time to time, mostly my profile widget is meant to show my own tweets. So, both the avatar and the user name before each tweet are basically redundant and just make the widget look all cluttered. So, I’d really appreciate if Twitter could restore the option of not showing the avatar + user name next to each tweet.


#7

This is broken on several of my sites today too. Avatars and the user name are showing up even though the configuration says not to show them. It makes the widgets look horrible and totally screwed up the layout, squishing all the text up into the right corner. Very annoying. Does anyone have a fix for this yet? Or is there an ETA until twitter pushes a fix out?


#8

Interesting, I notice this bug doesn’t affect the twitter resources page - when you uncheck the avatar box, it correctly removes the image and username on the widget preview. Whatever the bug is, it only affects live widgets on our pages but not twitter’s own website.


#9

Yeah this has totally broken our portal which is deployed to over 20 sites. I suspect most developers have fit this widget into a very specific section of their page - planning the entire design and real estate of the page around this. To suddenly change the widget to require much more space is a big mistake IMO. I hope that Twitter can put back in place the option to have the avatars on or off.

Further more, why is the ‘avatars’ configuration property still included in the javascript block on the widgets page if the property is ignored? I hope this can be re-thought through a bit more clearly.


#10

Ok, here’s a temporary CSS fix that’s working for me. It’s not ideal but should do until someone at twitter can push a real fix. Just cut-and-paste it into the CSS for the page where the twitter widget lives.

/* fix for twitter widget bug that ignores avatar setting */
.twtr-tweet-text { margin-left: 0px !important; }
.twtr-user { display: none; }
.twtr-avatar { display: none !important; }


#11

Just installed the widget last night and woke up to find it not doing what I told it to do.
I’m sure there is good reason to change your Display Guidelines, but instead of subtly breaking the layout of many 1000s of sites, a better approach would be to respect how your api users have specified things, and change it for your new api users.


#12

Broken on my site too… :frowning:


#13

I agree with all these posts. It is ASININE to make this change without telling anyone. Like one or two of the other posters, I have this widget placed in a narrow sidebar of a site (narrow because of what else is in there), and it makes the thing look ridiculous, with tweets jammed up to the right-hand side, and occupying 5 or 6 lines. I have taken it off the site and shan’t reinstate it until this is fixed.


#14

I think it’s time to think of writing our own script to display twitter feeds. :slight_smile: It has changed the widget background colour to just white on IE9. Thanks to @steevithak I was able to hide the avatar display.


#15

I hope the following code will help many of you to customise the look and feel of the twitter widget via CSS tweaks.

profile

Tuts+

tutsplus

tutsplus If you like Rockable books, consider following Rockable on Twitter (@rockablepress) or Facebook (http://www.facebook.com/...) 2 days ago · reply


#16

Thanks for the CSS fix, but it’s still annoying that this has been done


#17

Just noticed this on my site this morning. It looks so wrong to have the same avitar repeated with each tweet, @steevithak work around works …fair play …now following!


#18

Thanks @steevithak for this CSS workaround. Much Appreciated!


#19

No options from the “features” are working i think?
These are realy bad changes :confused:


#20

I too thank Steven. It works beautifully on my site!