Authorize OAuth with force_login=1 from Firefox doesn't work


#1

Hello,

All browsers but Firefox work perfectly authorizing the app to use the user account. But when I try it from Firefox it keep asking user/pass all the time.

I notice if I remove the “force_login=1”, then it authorize correctly (but from the current user session in Twitter).

I have tested from different firefox and os versions.

Users have confirmed that yesterday worked fine from Firefox.

Any idea about it?


#2

The same problem started for us on Friday, June 27. Users using Firefox and Internet Explorer get stuck on the authorize page on api.twitter.com and never get redirected back to the callback URL. They do get redirected back to the callback URL in Google Chrome.


#3

I just changed from authorize to authenticate and It looked it works, but after a few tries with different accounts we noted that some accounts can’t login either, we tried different browsers. Just keeps looping/showing us Twitter auth page.

We have discovered that if you revoke access from Twitter Apps to Jooicer and then try to authenticate again, then it works well.

I don’t know if both errors (authenticate and auhorize) are related.

Any tip ?

Thanks.


#4

Now everything is working fine, without any change…