Authorisation error

ads
api

#1

Hi guys,

We’ve been granted developer access (received the email) however we get this error every time we use twurl:

{“errors”:[{“code”:“UNAUTHORIZED_CLIENT_APPLICATION”,“message”:“The client application making this request does not have access to this API”}

Here is our Consumer key: LaPVOLRX15NekeJm7AVdU4bWy

Thanks,
flobox


#2

We received this email:

Congratulations! Your application has been approved for the Twitter Ads API program and your organization has been granted a Developer license.

ADS API - DEVELOPER ACCESS
The Developer license provides access to all Ads API endpoints to develop your tool to completion. Developer-level partners are limited to five OAuth tokens and prohibited from exposing any Ads API functionality to external advertisers.

We did not receive any application ID or anything else.

Can we please get an update? Are we whitelisted? We’ve been banging our heads on this for days…

Owner ID: 735296722671259648

Thanks


#3

The App I see approved for you is “12424595” - can you please check which app you are attempting to use because the consumer key above may be coming from a different app.

Thanks,

John


#4

Hi & thanks for the reply.

Is it possible to approve for Consumer ID: I5diROFuSc9ro37w3LN4XR2SY?

That is the app we are currently using.

Steve


#5

Also, how do we check our App ID? That’s the first time I’ve seen that number (12424595)

or is App ID the same as the Consumer Key?


#6

The apps should be listed in apps.twitter.com for that handle (@flobox_io), one of the Program Managers would have to help you if you wish to switch it and you should contact them via whatever contact you already have, but it might delay things and from user perspective the app is invisible (literally the only place it’s exposed is when you log in to apps.twitter.com dashboard).


#7

Yes I can see my flobox app in apps.twitter.com.

I found my app ID (12424595) and it matches the one you provided.

I don’t want to switch anything. I just want to make sure my consumer key (I5diROFuSc9ro37w3LN4XR2SY) works…

Can you please verify that my consumer key is whitelisted?

Thank you


#8

I tried again, still failed.

These are my steps:

  1. twurl authorize --consumer-key I5diROFuSc9ro37w3LN4XR2SY --consumer-secret XXXX
  2. Get URL and PIN
  3. Use PIN - authorisation successful
  4. twurl -H ads-api-sandbox.twitter.com /0/accounts/
  5. {“errors”:[{“code”:“UNAUTHORIZED_ACCESS”,“message”:“This request is not properly authenticated”}],“request”:{“params”:{}}}

Any clues?


#9

Hi JBabich! Any updates?


#10

As far as I can tell, that App ID should be approved for Ads API already.

As an idea did you update the default profile that twurl is using?

Try typing “twurl accounts” and then "twurl set default ". The details of how twurl is doing authentication are stored in the .twurlrc file.

Which OS are you running twurl from? Is it 0.9.3 when you type twurl --version?

You might also try hitting the production endpoint instead of Sandbox to see if it makes a difference. Another option would be to use the Ruby or Python SDK which are not so difficult to set up, but it shouldn’t be much different and I would expect you to be able to get twurl working.


#11

OS is 0.9.3.

I checked out our accounts…it seems the default consumer key is an old one.

The new consumer key should be PnfCqz3ScaZwrSsVLwIUC4wKB (we regenerated the keys).

Would this be an issue?


#12

Worked!!! Yay thanks :slight_smile: