AuthenticateWith suddenly not working


#1

I have an application the tweets all of the legislative activity for Michigan and also MEETING that are happening with the legislature. It’s important, and also, it’s worked very well for a long time. Then it stopped working for all three of my twitter accounts. I tried changing my credetials but it didn’t help.

I can’t really see what’s wrong with it.

I do a;
tw.AuthenticateWith(ConsumerKey, ConsumerKeySecret, OAuthToken, OAuthTokenSecret)

and it doesn’t fail but I also think it doesn’t really authenticate.

Then I do a;

tw.StatusMethods.Update(myTweet)

and it fails with “object reference not set to an instance of an object” - this has worked fine literally for years.

any help on how to test or fix this would be great.


#2

I’ve switched to twitterizer (from twitter.vb), and I can at least see now that I’m getting a 401 Not authorized. Why am I not authorized? is there a place to go to find out why one would suddenly not be authorized? Is this something twitter might do to punish me if I posted too many tweets in a short period of time? If so, what can I do about it?