"Approved", but not approved


#1

I submitted my Twitter Card request earlier today and was pleased to get approved within a few hours, but when I test a tweet on the validation page I see a message that says “WARN: Not whitelisted” (see screenshot https://www.dropbox.com/s/lcpmlg6tvyosfvj/Screenshot%202014-09-16%2015.18.21.png?dl=0 )

Since it also says I’m approved, and I received my email, I thinking this may just be a little error, but when I tried testing this same link out on Twitter I noticed that the Twitter Card did not show up (see screenshot https://www.dropbox.com/s/4xmvxqex95uwl2l/Screenshot%202014-09-16%2015.21.04.png?dl=0 ). I wanted to see if there was an extra step I needed to do to get the actual tweet to show a card like I see on the card validation page… or maybe it just takes a couple days before it automatically works in tweets.


#2

There appears to be something a little awry with cards for a few days. I have the same thing happening with one of mine, see: https://www.dropbox.com/s/4dhig0pfa7esz2z/Screenshot%202014-09-16%2015.22.48.png?dl=0

However, other requests go through immediately, and work immediately once approved.


#3

Having this same issue - Have either of you figured out why or…?


#4

No fix yet. Just tried it again and I’m still showing up as

INFO:  twitter:card = summary tag found
WARN:  Not whitelisted

#5

Still hoping for a solution to this. I’m working on an article on how to install Twitter Cards, which was a really easy process, but now I seem to be stuck in some weird Twitter bug where I’ve been approved… but I’m not showing up as approved. The article is supposed to go live tomorrow so I’m not sure what to do. The meta data is there & I’m approved, but there’s clearly something now working with the whitelisting.


#6

Okay, I think I’ve found the issue, but I’m still waiting for clarification from anyone who has expertise in this area. It appears that when you apply for whitelisting you are requesting approval for just one style of card. When I applied for the card I had the “large image” card selected, but since then had decided I wanted to use the small preview card instead. This seems to be the cause of my issue. When I switched my site back to large image cards, the validator said everything was working.

The problem now is that I seem to be stuck with large image cards. When I switched my site back to the small preview card meta data, I am unable to submit an approval for those style of cards. I just get an “internal error” listing or “not whitelisted” error.

So suggestions for Twitter are:

  1. The error messages need to be more clear (ie "You are not approved for this type of card).
  2. Once approved for one type of card, there is no method for applying to any other types of cards.
  3. Whitelisting should be universal. Once approved for a card, sites should be able to switch whenever they like, so this mess doesn’t happen again.