Applications not visible in settings. Users unable to see application they granted permission to


#1

Here’s the problem. I created a simple App that allows users to post to their twitter stream. I registered it with Twitter and got the Consumer Key and Secret. I use those from my web application to route users to twitter to grant the application access … https://api.twitter.com/oauth/authorize?oauth_token=[TOKEN]. The page displays the application name and asks them if they want to grant it access. They enter their twitterId and password.

The application then retrieves the User’s Key and Secret from the trackback url. Two problems are occuring:

  1. The App is not showing in the users Settings/Applications list.
  2. The App gets a 401 (unauthorized) error when it tries to post a tweet through the user’s account.

It’s as if the user never granted the application authorization. I tried this with several twitter accounts and also reset the applications consumer key and secret.

What is wrong? This was working before.


#2

Sounds like the token exchange is never finished, that would explain why the app does not show up in Settings/Applications. Please check whether the exchange of the request token to an access token works correctly.

On callback, you receive the request token that has been authorized by the user in oauth_token and the verifier in oauth_verifier. Make sure that your app correctly exchanges this request token to an access token:

  • Check that you make a POST to /oauth/access_token with the oauth_verifier as parameter, signed with the request token and its secret (which you should have stored when retrieving the request token).

  • Check whether the answer to that POST looks like:
    oauth_token=XXXXXXXX&oauth_token_secret=XXXXXX&user_id=12345678&screen_name=a_screen_name


#3

I’m getting the same problem. Did you found the reason? How can I fix it?


#4

hi