Application won't set to 'read and write'


#1

Hello, I am trying to integrate twitter with wordpress, in order to do this I need to set the application I have made for @jonefelicity to ‘read and write’, however every time I save the settings this reverts back to ‘read only’ - please tell me why this is. Thank you.


#2

I’ve been seeing something similar. Apparently Twitter is perpetually ‘Over Capacity’ at the moment and every time it tells me it’s ‘Over Capacity’ when I try to register an application it seems to create a broken copy of that application where the icon isn’t installed and I can’t change the icon or the read and write setting afterwards. I have to delete it and try to register it again but it’s always ‘Over Capacity’.

Hopefully one day it will work without being ‘Over Capacity’, but if you hit the same ‘Over Capacity’ screen when registering you might want to delete it and try again.


#3

Just like @jonesfelicity : Trying to install the same app for WP, same pb. A twitter support staff to enlight us?


#4

I’m also unable to change any of my application settings (read/write, app icon, etc.).


#5

Having exactly the same problem. No changes takes effect.


#6

Same, we need a fix!


#7

It can sometimes take a few minutes (and sometimes as much as an hour) for changes to your applications to be reflected on dev.twitter.com. If you’ve waited for your changes to take effect longer than a few hours and they’ve still not changed, please let us know.


#8

I’ve waited a day. No change


#9

Having this same issue. Would love some feedback from Twitter. In developer, I change my app to “read and write”, and though in dev it shows it as changed, from my twitter page it still displays as read-only and my app won’t publish tweets from wordpress.


#10

ah ha. Figured it out. In developer, under ‘details’ one must ‘recreate their access token’. Then, in WP, I also had to ‘unlink’ the plugin from twitter, and re-enter the consumer secret, etc., then re-link to twitter. Now it’s changed to read and write.


#11

Thank you for telling me that!!!


#12

Thanks UTheos, it worked for me too!!


#13

Thank you UTheos, it worked for me too!


#14

That didn’t work, i keep getting this message: Error
You must add your mobile phone to your Twitter profile before granting your application write capabilities. Please read https://support.twitter.com/articles/110250-adding-your-mobile-number-to-your-account-via-web for more information

Have tried doing this but Twitter doesn’t have my carrier added, so what are we supposed to do to change our permissions.?


#15

the same thing


#16

Hi @cecc55 & @gongzhen1027, If your carrier is not currently supported please contact our Platform Operations team by using the “I have an API policy question not covered by these points” option at https://support.twitter.com/forms/platform