Application went missing


#1

Wasn’t exactly sure what category to put this in, hopefully this is correct:

I have a little toy application I made just for fun to allow “longer tweets” aka a link to a post on a site I run. It’s just for fun, I don’t make anything off it, just wanted to write a ruby app and play with the twitter api.

Today I find that my application is no longer working, and when I go to look at my application settings, the application is simply missing… I’m certain it’s the correct user, I’ve tried the only other use I use for personal twitter stuff, and it isn’t there either.

Anyway, I just created a new one (though I had to use a new name, it said the old one is taken…) but I cannot seem to post on behalf of a user (using the ruby twitter gem), though I can post as myself just fine; but the more interesting thing is while I was playing around with it trying to make it work again, in the application details tab, the “Your access token” section disappeared as well! It required I recreate it (though it still won’t let me post on behalf of another user).

So, my real questions are: what happened to my original application - am I violating some policy and having stuff silently deleted? I don’t intend to.


#2

FYI the new application name is “Tbig”, the old one is “tbig.co”. I still see the old one listed in my “authorized applications” section as a client; though strangely it has this line:
Approved: Wednesday, May 1, 2013 6:46:32 p.m.
which is today not long ago (after I had created the new app and started using its credentials)… so I’m not sure what is up.


#3

Side note: I figured out the issue with posting on behalf of a user, so my real question is:

where did my application go?

It’s not the end of the world - it’s just a toy app, but I’m quite certain the user I used to register the original application is the same one I’m using now.


#4

I can tell you that @tbig_co does not own the application with the name “tbig.co” – I can’t tell you the name of the user that does own the application for privacy reasons but the screen name does start with a number character.


#5

Yeah. I just figured it out… it was a different account I had set up before I found a name I liked; and I had forgotten. Please feel free to delete this thread, sorry for the waste of time, and thanks for the help!