Application getting stuck in read-only after updating settings


#1

I’ve been getting 401 “Could not authenticate with OAuth.” errors and looked into my application settings to find my app in read-only permissions mode.

After updating the app to read/write or read/write/DM modes and saving the form the app returns to being read-only. I’ve tried updating some existing applications under my account and another test account and those too show the same signs – in some cases, going from read/write to read-only after changing other settings such as the application website. I’ve tried refreshing consumer key/secret to no avail.

Is anyone else currently experiencing this and, if so, has anyone been able to figure out what’s going on or any workarounds?


#2

There’s some heavy caching on dev.twitter.com (in addition to the methods it uses to update/read application data) – once you make the save, it should take after a few minutes (at most hours if the queues are really backed up). Once changing the application level permission level, you’ll then need to renegotiate any access tokens set to that previous level. Now that some time has passed has you app updated?