App user authorization suddenly doesn't work


#1

Hello! I have created the twitter login flow the day before yesterday, and everything worked fine, I managed to add one user to my application, by authorizing my twitter app. But yesterday I started to receive the error

The Twitter REST API v1 is no longer active. Please migrate to API v1.1. https://dev.twitter.com/docs/api/1.1/overview.

Even though I am using the v1.1 of the API!

I removed the user from my app and I tryed with another user, but the same error occurs with every user I would try. And now I can’t use the API because I don’t have any valid user I could use for this.

This error occurs after I get valid access tokens (token and secret) and when I try to make a request to GET account/verify_credentials.

I have a Zend application and I am using the Zend Twitter Service, and I want to emphasize that the user authorization I developed worked just fine until yesterday, without me changing anything. I used the example at the http://framework.zend.com/manual/current/en/modules/zendoauth.introduction.html, but with siteUrl as https://api.twitter.com/oauth.

Is this a Twitter bug?

Thanks!


#2

Can you please post more information, about what URL exactly you are using, where the error occurs?


#3

Oh I feel so dumb :blush: … I was instantianting the wrong class, and instead of making requests using https://api.twitter.com/1.1/, I was making requests using https://upload.twitter.com/1.1/.

Thank you for making me look again now at the exact request I was making! So glad this works now… :relieved:


#4