App not found after account activity API appliaction approved


#1

I applied an app to access the account activity API to make a bot and I received the approval about two weeks ago. but when I logged into my twitter account, I didn’t find any app. Only the create a new app option. I thought that maybe the account has been approved to use the API so I created a new app and tried to register a webhook but still getting the same error before approval (could not authenticate you with code 32).

I’m really lost as I can’t even test the app that has been approved since it is not show in my apps. What should I do? I need to make a bot as soon as I can and I still can’t even register a webhook.


#2

Any help would be really appreciated … I couldn’t find the accepted app so I can’t register a webhook and start building the bot.


#3

@RTTestAcc - If you were approved, the approval would have been sent to your email address connected to your @handle used to apply. The confirmation should also confirm your environment name of env-beta and the AppID that was whitelisted for the beta.
Can you re-check your email?


#4

To be clear:

  • when you are logged in to your account on twitter.com, navigating to apps.twitter.com should show your list of apps. This is where you would have taken the app ID from when you applied for access to the Account Activity API beta.
  • once approved, you should have received email confirmation with the environment name (env-beta). During the beta, this will not show up in the developer dashboard on developer.twitter.com, but in the future, you’ll see something there.

#5

Thanks for your reply. Here is the body of the email I received:


Your Twitter developer account application has been approved!

Thanks for applying for access. We’ve completed our review of your application, and are excited to share that your request has been approved.

Sign in to your developer account to get started.

Thanks for building on Twitter!


So since there is no app id and no environment name, does that mean there was something wrong in my application (like missing App ID) cause when I checked my apps on apps.twitter.com after receiving the email, there were no apps (even though as I recall I had one app that should have been mentioned in my account activity API application).

What should I do now? I created two new apps but since the approval seems to be per app and not per account, they are not working. Can you approve an app in the same account that was accepted or must I apply again with new app id and wait again? I’m really in a hurry since I have to make a POC of a chatbot that at least answers direct messages (and preferably also tweets) for an organization account, and applying another application might take up to 2 weeks again.


#6

the new apps that I created after approval that don’t work are:

Account: RTTestAcc

  1. App Id: 14795885
  2. App Id: 14796829

#8

@andypiper @happycamper can you please suggest what should I do to start as soon as possible?


#9

@RTTestAcc - Only one app is allowed for beta access, this is the app that you applied with and is connected to the email and @handle you received that email from.

To test-
Get a bearer token with your app credentials for your approved app:
$ curl -X POST “https://api.twitter.com/oauth2/token” -u “clientkey:clientkeysecret” -d “grant_type=client_credentials”

Then run this command with your Bearer token:
$ curl --request GET
–url https://api.twitter.com/1.1/account_activity/all/webhooks.json
–header ‘authorization: Bearer TOKEN’

You should get this if you’re approved:
{“environments”:[{“environment_name”:“env-beta”,“webhooks”:[]}]}


#10

@happycamper Thx for your response. Can you provide me with the App Id that got accepted? cause as I mentioned before, when I logged in after receiving the approval there were no apps. And even if in my application I didn’t fill it correctly (like wrong app id or something), I shouldn’t have received an approval email. I should have received a note telling me that something in my app is missing. Anyways, it seems that I have to make another account and apply for access to account activity API all over again cause I have demo to a customer soon and I can’t even start (and he’s getting pissed off cause I keep pushing the date). For now I’m just writing some code based on the docs since there is no other way but webhooks to actually build the bot.

Thanks anyway for your response. Even though the process of approval and starting making bots is frustrating (specially when compared to other providers like FB which I started almost instantly and actually almost done), but you guys respond and help the developers in a good way which is really appreciated. Thx for your help :slight_smile:


#13

@RTTestAcc- Which app do you want whitelisted for AAA beta? We can only set up one of your apps:
App Id: 14795885
App Id: 14796829
or
App Id: 14803157


#14

App with ID: 14795885. Many thanks, you rock :grinning:


#17

@RTTestAcc you should be good to go using the dev environment called env-beta


#19