App Cards not showing despite approval


#1

Hello, I recently got the url http://www.millennialeye.com whitelisted for use of an App Card, but am only seeing a “View on Web” link wrapping back to the same domain in the validator and when tweeting. Perhaps I am missing something with my meta tags? They appear as such:

<meta name="twitter:card" content="app">
<meta name="twitter:description" content="Millennial EYE is an all digital, app-based publication and online community targeting the future leaders in ophthalmology.">
<meta name="twitter:app:name:iphone" content="Millennial Eye">
<meta name="twitter:app:id:iphone" content="628431593">
<meta name="twitter:app:url:iphone" content="https://itunes.apple.com/us/app/millennial-eye/id628431593?mt=8">
<meta name="twitter:app:name:ipad" content="Millennial Eye">
<meta name="twitter:app:id:ipad" content="628431593">
<meta name="twitter:app:url:iphone" content="https://itunes.apple.com/us/app/millennial-eye/id628431593?mt=8">
<meta name="twitter:app:name:googleplay" content="Millennial Eye">
<meta name="twitter:app:id:googleplay" content="com.brynmawr.me.android">
<meta name="twitter:app:url:googleplay" content="https://play.google.com/store/apps/details?id=com.brynmawr.me.android">

I would like to know If something is wrong with the meta tags that is preventing links to the app from displaying, as well as if a link to a particular store will only display on a device that can download it. Also, I would like to know exactly what needs to be tweeted to trigger the card - I thought it was just the domain, but now I’m not so sure.

Any and all help is greatly appreciated!