App card not showing

cards

#1

My app card was working but now it’s not showing on my tweets. It also validates OK. Can anybody suggest what is going wrong? http://www.geo-coach.com


#2

Seems to be working for me when I click into the Tweet detail view?


#3

Hi Andy, it’s still not there for me. Attached is a screenshot from my
android phone from a tweet earlier today. I get the same on desktop too.
The url is displayed instead of the card. This is the same on my pinned
tweet but if I look back across my tilelime I can see it in older tweets.

Thanks


#4

Unable to see the screenshot. I Tweeted a link last week and the card shows on web and mobile for me (and did at the time as well). There’s a chance the rendering may have just been slower on a few Tweets, I suppose. Remember that cards only show up in Twitter’s own apps, they are unfortunately not available in third party apps.

example


#5

Hi Andy, here is the screen shot from my email which was taken from the official Android twitter app

I get the same result viewing via Google Chrome


#6

It looks like you’re also attaching an image to your Tweet? You cannot have an image attachment as well as having a card displayed. You have to choose one or the other.


#7

Thanks Andy, that will be the problem.


#8