API wont return any result anymore


#1

Suddenly my twitter api app stopped returning results at all, and i have no reason why its happening !!
i’ve tried to use diff API tokens, but no luck.

i even tried to use a very simple php api script but also no luck.

Any help please ?

here is the code

<?php
require_once('TwitterAPIExchange.php');
/** Set access tokens here - see: https://dev.twitter.com/apps/ **/
$settings = array(
'oauth_access_token' => "xxxxx",
'oauth_access_token_secret' => "xxxx",
'consumer_key' => "xxxx",
'consumer_secret' => "xxx"
);
$url = "https://api.twitter.com/1.1/statuses/user_timeline.json";
$requestMethod = "GET";
$getfield = '?screen_name=manutd';
$twitter = new TwitterAPIExchange($settings);
$string = json_decode($twitter->setGetfield($getfield)
 ->buildOauth($url, $requestMethod)
 ->performRequest(),$assoc = TRUE);

if($string["errors"][0]["message"] != "") {echo "<h3>Sorry, there was a problem.    </h3><p>Twitter returned the following error message:</p><p><em>".$string[errors][0]["message"]."</em></p>";exit();}
echo "<pre>";
print_r($string);
echo "</pre>";
?>

Thanks in advance


#2

Please tell me you have an answer?
I have the same problem! Maybe it’s TwitterAPIExchange?

I still don’t know…


#3

Hi there!

Not sure, but you can always try our developer console here:

https://dev.twitter.com/rest/tools/console

You can auth via your same account and make API calls using the API, to see if it’s the toolkit you’re using or our API directly.

Does that help?