API v1.1 search problem with hashtag containing scandic characters


#1

After upgrading to API v1.1 using Net::Twitter Perl module I’ve faced an issues for searching tweets containing a hashtag that includes letters ‘ä’. This worked just fine with v1. I’ve tried every possible encoding yet thought which don’t return any results for the correct hashtag. If I try it as it was working with v1 I will get the “Could not authenticate you” error.

So does anyone know how to correctly search tweets with hashtag containing scandic letters? Could also be an issue with Net::Twitter, I will try to debug that now because I’ve fallen short of ideas right now.


#2

Ok,

well actually worked this out. As stated somewhere the terms need to be correctly urlencoded and that means that the utf-8 character ä correctly urlencoded is %C3%A4. So using “%23somewith%C3%A4char” will work as a searchterm. Seems that the v1 was a bit loose and it might have been working with slightly “wrong” encoding - probably that api v1 worked also with just utf-8 encoded characters.


#3

You are totally correct! The strictness of HTTP 1.1 and OAuth 1.0A employed by API v1.1 requires that all reserved characters be percent encoded. API v1 was very tolerant to errors.