API Twitter integration fails

ios
cocoapods
twitterkit

#1

Hello everyone, im try to install Twitter with fabric, the steps with fabric are so clear, but when i try to login with my app, the app close and show me this error:

Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'TwitterKitResources.bundle file not found. Please use the Fabric Mac app to ensure TwitterKit is properly set-up.'

i already created a pod with fabric and twitter dependency. In my code, Xcode found the libraries, in my pod folder i have, TwitterKit, TwitterCore and ofcourse TwitterKitResources.bundle, i try copy TwitterKitResources.bundle in my principal project too, and neither, before this problem i have a dependency problems with fabric and twitter but no anymore, now thats is the problem.


#2

Hey @ed_olii,

Can you share the contents of your podspec and how you have Fabric initialized within your app so I can double-check those?

-Mike


#3

Hey @bonnell my podspect, (my pod name Test):

s.requires_arc = true

s.subspec ‘iOSTwitter’ do |iOSTwitter|

            iOSTwitter.ios.deployment_target = "9.0"
            iOSTwitter.source_files = 'Test/Test/Source/Twitter/*.{swift}'
            iOSTwitter.dependency 'TwitterKit'
            iOSTwitter.dependency 'TwitterCore'
            iOSTwitter.dependency 'Fabric'
    end

and in my app delegate, i have:

Twitter.sharedInstance().start(withConsumerKey: “MY_CONSUMERKEY”, consumerSecret: “CONSUMER_SECRET”)
Fabric.with([Twitter.self])

Thanks


#4

Thanks, can you try removing TwitterCore from your Podspec and let me know how that goes?


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.