API "/oauth/request_token" returns {"errors":[{"code":215,"message":"Bad Authentication data."}]}

oauth
api

#1

Hi, guys
I have tried to connect from web-app to get token for my application account, but Twitter returns the error message like this:
{“errors”:[{“code”:215,“message”:“Bad Authentication data.”}]}
Anybody know something about this error?
PS My request:

POST /oauth/request_token HTTP/1.1
Host: api.twitter.com
Authorization: OAuth oauth_nonce="…mynocne…",oauth_signature="…myConsumerSecret…5Gl%26",oauth_callback=“http%3A%2F%2F…MyServerIPwithoutPort”,oauth_consumer_key="…myConsumerKey…",oauth_signature_method=“PLAINTEXT”,oauth_timestamp=“1492184500”,oauth_version="1.0"
Content-Type: application/x-www-form-urlencoded;charset=UTF-8

Response:

HTTP/1.1 400
status: 400
cache-control: no-cache, no-store, must-revalidate, pre-check=0, post-check=0
content-disposition: attachment; filename=json.json
content-encoding: gzip
content-length: 87
content-type: application/json; charset=utf-8
date: Tue, 18 Apr 2017 13:09:36 GMT
expires: Tue, 31 Mar 1981 05:00:00 GMT
last-modified: Tue, 18 Apr 2017 13:09:36 GMT
pragma: no-cache
server: tsa_o
status: 400 Bad Request
strict-transport-security: max-age=631138519
x-connection-hash: 12f2d480c5011dc52fd477b02c35c281
x-content-type-options: nosniff
x-frame-options: SAMEORIGIN
x-response-time: 101
x-transaction: 0005b32c00ee1be5
x-twitter-response-tags: BouncerCompliant
x-xss-protection: 1; mode=block

{“errors”:[{“code”:215,“message”:“Bad Authentication data.”}]}


#2

How are you generating the request?


#3

I used DHC for test. For generate Authorization was used PEGA application with common features (connectors to Twitter).


#4

This is the connector’s Authorization settings


#5

I don’t know what any of those acronyms mean but the signature method should be HMAC-SHA1. Do you have any code sample?


#6

Thanks a LOT Abraham!!! It’s worked now)))