API integration of tweet is working, however, when searching by hashtag, the tweet is not appearing (it is appearing in user's feed)


#1

We have integrated twitter’s share API to the website: www.rentauctioneer.com

When clicking on a specific listing: http://rentauctioneer.com/berkeley/listing_2500-durant-ave
there is a twitter share button. This successfully creates a tweet on the user’s feed - working fine.

However, as part of the message is the hashtag: #rentauctioneer - when clicking thru on the hashtag, these tweets are not appearing.


#2

Not all tweets are indexed by search:

[faq:8650]


#3

I have reviewed the documentation /notes that you have provided. I understand that not all tweets are indexed and shown on a search. However - ALL of the tweets that are manually captured on my handle are showing on the hashtag search #rentauctioneer, while NONE of the tweets that are integrated from the web site via the API onto my handle are showing up on the search.

This tells me that there is an issue with the API integration. We went back and checked that they were not set to ‘private’ and re-checked all other settings.

Please advise


#4

I have reviewed the documentation /notes that you have provided. I understand that not all tweets are indexed and shown on a search. However - ALL of the tweets that are manually captured on my handle are showing on the hashtag search #rentauctioneer, while NONE of the tweets that are integrated from the web site via the API onto my handle are showing up on the search.

This tells me that there is an issue with the API integration. We went back and checked that they were not set to ‘private’ and re-checked all other settings.

Please advise


#5

I had the same problem, but it’s because you can’t use the Search API to find Tweets older than about a week
https://dev.twitter.com/docs/using-search


#6