All Wordpress widgets to pull Twitter RSS feeds are now failing on my blog (other RSS feeds are fine) -- last 24 hours


#1

For almost a year my tweets have been displaying fine on my Wordpress blog without any issue what-so-ever, and yesterday morning my regular tweet at 9:00am appeared on the blog at 9:04 (the tweet’s time stamp indicated it was 4 mins old). My blog has a plugin to retrieve the tweets every 30 minutes however 30 mins later it started reporting an error while retrieving the tweets, which still remains.

I traced the problem in the plugin code to the line of code that calls the WordPress function to fetch the feed:

$feed = fetch_feed(‘http://twitter.com/statuses/user_timeline.rss?screen_name=’ . $username);

where $username is my twitter name. Nothing is returned by fetch_feed and thus $feed is an invalid object. If I try and fetch any twitter name (not just my own) they also fail, however if I change it to fetch other RSS feeds (not twitter) there is no error and they are retrieved and displayed (although somewhat truncated). For example, I’ve tried the following without error:

$feed = fetch_feed(‘http://www.theglobeandmail.com/?service=rss’);
$feed = fetch_feed(‘http://www.nature.com/nature/current_issue/rss’);
$feed = fetch_feed(‘http://www.theismaili.org/rss.xml’);

The plugin developer advised me the following:

The fetch_feed function is essentially only a
wrapper for the SimplePie library that comes with WordPress, see here:

http://codex.wordpress.org/Function_Reference/fetch_feed

I think the best you can do is checking if the SimplePie object has
any error message and what the error is. Just like here:

http://simplepie.org/wiki/reference/simplepie/error

I tried the following code from simplepie.org

$feed = new SimplePie();
$feed->set_feed_url(‘http://twitter.com/statuses/user_timeline.rss?screen_name=’ . $username’);
$feed->init();
$feed->handle_content_type();

if ($feed->error())
{
echo $feed->error();
}

And it reported the error “URL error 28: connect() timed out!”. I have noticed that while the twitter plugin is active, pages are taking a long time to load (no doubt due to this time-out). If I deactivate the plugin, pages load instantly.

I tried the following twitter plugins for Wordpress and they all gave the same problems too:



One of these allowed me to extend the time-out period but it made no difference.

I upgraded a test version of the blog I have from Wordpress 3.01 (what I’m using) to version 3.2.1 (the latest version) and I’m still getting the error.

So since the only time I get the error is with twitter RSS feeds, regardless of which Wordpress version or twitter plugin I use, and don’t get errors with any other RSS feeds, it would seem something subtle has changed at twitter, even though twitter RSS feeds work find my browser and other RSS applications, and many other Wordpress blogs.

Any help would be much appreciated.


#2

I’m getting the same error as well. I heard that some IP addresses might have been blocked? Is your site slow?


#3

Yes the site is slow when I have the twitter widget active (because it seems to be trying to get the tweets and locks up the page until it times out with a failure). If I remove the twitter widget, the site works at normal speed.


#4

I tried contacting Twitter about this, but they’re off for the long weekend (i.e. limited service only). It’s probably an IP address issue.


#5

My hoster advises me that twitter is blocking their IPs for some reason and they are working on resolving it with twitter.


#6

Did they say how long this is going to take?


#7

I asked. They just said they are working on it and didn’t know how long it will take.


#8

At least they are working on it… hopefully someone just tripped over a socket on a wall or something


#9

I am having the same problem. Haven’t changed a thing on my Wordpress blog, but suddenly my tweets are not updating to my blog, and my blog posts are not being tweeted out. How do I contact Twitter for support? Can’t seem to find an email address.


#10

Yesterday, I installed “YOURLS: Wordpress to Twitter” on my Wordpress site for the first time, but was unable to connect to my Twitter app (even after several retinstalls and recreating keys, read/write tokens, etc. and checking server time). I then tried other similar plugins: “WordTwit”, “WP to Twitter” and “Tweetable”. In all cases, I could not connect to the Twitter app.

This morning, I reactvated “WP to Twitter”. During setup, this plugin checks the Twitter server time. Last night, it couldn’t connect, but this morning it reported the Twitter server time correctly. I was then able to authorize and complete the setup without any problem.

I conclude there was a Twitter server problem that has now been resolved. I hope your posts are now being tweeted okay.


#11

Still not working. It must be something really bad…I’m on Bluehost. Are there other services affected too?


#12

I’m on bluehost too – I’m working now. Perhaps the IP for your server is still blocked.


#13

I’m on Bluehost, too. Guess that solves it. In fact, I did get an email from them today saying:

"Thank you for your email. We have support tickets into twitter and are working with them to resolve the issue. Currently the only way around this is to purchase a dedicated ip. The dedicated ip addresses are not blocked. Before we can proceed, we will need you to validate ownership of your account. To validate, provide one of the following:

  • The last four characters of the password on your account.
  • The last four digits of the credit card on file.
  • An Invoice # (not Transaction ID) and date of a Paypal payment to your hosting account.
  • Your PIN, set up from cPanel -> Profile/Billing tab.

Thank you,
Michelle
Level I Tech Support Engineer
BlueHost.com
888.401.4678


#14

I’m on Bluehost and I don’t have a dedicated IP. The problem I had (WordPress connecting to my Twitter account) had resolved itself by Tuesday morning.


#15

The Twitter API has been recently updated and this started to affect some of our WordPress websites that use the GoodLayers Twitter Widget. It seemed to be affecting other twitter widgets as well.

If you find the feed isn’t working, hopefully this will help:


#16

Take a look at this one. It works fine…

or here

http://ramsich.com/twitter-in-wordpress-plugin/#.URAMMkJZHRU


#17

you can try the Really Simple Twitter Feed Widget, with fresh support for the Twitter API 1.1


#18

I’ve also developed a plugin for WordPress to handle this with v1.1:


#19

Hi all try this plugin
http://themefantasy.com/plugin/twitter-rotator-wordpress-plugin/


#20