Account activity webhook replies with 214



I’ve been trying to register the crc for an account activity API webhook. I’ve created a quick and dirty crc response using flask and a self signed SSL certificate. The code for the CRC challenge is the following:

app = Flask(__name__)
sslify = SSLify(app)

@app.route('/default', methods=['GET'])
def default():

# Defines a route for the GET request
@app.route('/webhooks/twitter', methods=['GET'])
def webhook_challenge():

  # creates HMAC SHA-256 hash from incomming token and your consumer secret
  key_bytes= bytes("my consumer secret" , 'utf-8')
  data_bytes = bytes(request.args.get('crc_token'), 'utf-8') # Assumes `data` is also a string.
  sha256_hash_digest =, msg=data_bytes, digestmod=hashlib.sha256).digest()

  # construct response data with base64 encoded hash
  response = {
    'response_token': 'sha256=' + str(base64.b64encode(sha256_hash_digest))

  # returns properly formatted json response
  return json.dumps(response)

context = ('cert.pem', 'key.pem')
if __name__ == "__main__":"", port=443,ssl_context=context)

and the code to trigger the crc challenge is the following:

from requests_oauthlib import OAuth1Session
import urllib

CONSUMER_KEY = 'my consumer key'
CONSUMER_SECRET = 'my consumer secret'
ACCESS_TOKEN = 'my token'
ACCESS_SECRET = 'my secret'

twitter = OAuth1Session(CONSUMER_KEY,
webhook_endpoint = urllib.parse.quote_plus('')
url = '{}'.format(webhook_endpoint)
r =
from pprint import pprint

Unfortunately, I keep getting a 214 error that I can’t find an explanation for. It says:

“code”:214,“message”:“Webhook URL does not meet the requirements. Please, check your SSL Configuration.”

However, I am not getting any request logged in flask, is this just because my ssl certificate is self signed? My problem is likely similar to:

which is the only instance I have found of the same error message.


Have you reviewed our recommended server configurations section on this page?


Yes, it’s a grade A on
I using a digitalocean free ssl , may be this is the problem ?
Is twitter not agree about free ssl certificate ?


That should not be a problem, but without knowing the URL for the webhook it is difficult to help to troubleshoot.


This is my webhook

I purchased a new ssl certificate but the same response.
Please help me


This is my webhook

I purchased a new ssl certificate but the same response.
Please help me


Please don’t post duplicate comments, this doesn’t help anyone. We can try to check the endpoint when we have time.


I’m sorry, i just was assign the comment to you.
I’m waiting your replay


Have you tried using our boilerplate app? I suggest you try this and use a Heroku app and see if you can get that up and running. Then, try swapping out the Heroku app website for your webhook URL.

closed #11

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.