Access Tokens Disappears after sending messages

token
directmessages

#1

I wrote a script using a Laravel package (https://github.com/thujohn/twitter) to send direct messages to my followers. So far it’s worked great. Today it sent about 40 messages, and suddenly failed.

After some investigation I found that I was getting an [89] Invalid or expired token error. I checked my app and found my access tokens had vanished. So I regenerated them, updated my app, and tried to resume. Same thing, after about 40 messages, it started returning the same error.

I checked again, and the tokens I had just generated are gone. Why would this happen?


#2

Do you have a verified email address and phone number associated with your account / account associated with the app? Are all of your DMs similar or identical in nature? I don’t know for sure, but some aspect of our automation policy and rules may be throttling your script.


#3

Yes, I have an email and phone associated with the Twitter account.

Yes, I am sending the same DM to multiple followers at once, but I’m not sending the same message out more than once to the same follower.

I only have 580 followers, and I only send a message out every couple of weeks, at most, so I’m no where near the 1000 DM per day limit.