Ability to disable autoPlay or autoStart on embedded tweets with video?


#1

Is there a way to disable autoPlay or autoStart on tweets that have video embedded in them? I think it is part of the guidelines that providers themselves should not be auto-playing videos, but shouldn’t that just get forced to be false by Twitter and/or an optional flag for the embedding client (me)? Here is an example of one: https://twitter.com/TWCBreaking/status/418523427621076992 If you embed that tweet on a page, it just starts playing video and sound, and you may not know why or where that’s happening.


#2

Hi Ben,

Sorry for the delay.

The example you provided didn’t auto-play for me, but I’ll have other people look at it.

That said, the policy only allows auto-play for videos < 10 seconds.

Thanks,

Ryan


#3

Hi Ben,

There’s no way to interface with Card content to control autoplay at this time, unfortunately, but in cases like this you can hide the card for an individual embedded Tweet by adding data-cards=“hidden” to the embed code.

Ben


#4

Has this option been added anywhere since this thread? I know it only plays for 10 seconds but I don’t want it to play at all - I want to disable auto-play like I can in Facebook. Thanks


#5

Is there any follow up to this? It seems Benward’s response would mean you can’t publish cards >10 seconds because there is no way to prevent autoplay. Why isn’t autoplay turned off by default on cards?


#6