A problem

android
appinventor

#1

I keep getting this error and I dont know how to fix it, can anyone help? and I checked my consumer key and consumer secret are correct


#2

Are you using Twitter4J? Are you able to share any example code (please don’t post your API keys or secrets)


#3

Im using MIT app inventor 2 and this is the code that i have for it


#4

OK. I hadn’t used MIT App Inventor before today, but I have now! :smile:

I’ve just tried to use an example app both in the emulator and on my Android device, and managed to get it to work.

I think the error you are seeing here is because of the way you have configured your app on apps.twitter.com.

Go back to the page where you have set up the app on apps.twitter.com. Switch to the Settings tab, and enter a placeholder value in the Callback URL field (e.g. http://localhost.com). Then, click the Update Settings button.

Let me know how this works for you.


#5

I tried it but it still gives me the same error, what has to be my Callback URL?


#6

The callback URL should not matter, but it should be completed with a URL value in order to avoid this issue. I’m surprised if that still has not helped. Try setting to the same as the app URL that you have in settings.

If it helps, I tried using an app from the App Inventor gallery “twitteranoka2” and it worked fine for me, but I cannot tell you how that one is configured on apps.twitter.com


#7

http://ai2.appinventor.mit.edu/#4663994897399808/twitter/callback this is what I’m using as the callback URL but it still giving me problems which I don’t understand why because I don’t see any problem with my code, if its possible can we contact each other via email? it would be easier to communicate there than here my email is salim.elewa@hotmail.ca if thats okay with you of course! I appreciate the help so far thank you so much!