403 Forbidden using Web Intents Share when not logged into Twitter on iOS6


#1

Hi,

Currently have a link on a webpage using web intents share. Works perfectly fine on most devices and platforms. But on iOS 6 devices I hit a forbidden page when submitting the tweet with login credentials.

Here are my steps to reproduce:

  1. On iOS 6 device log out of twitter app and twitter on browser
  2. Visit https://twitter.com/intent/tweet?text=test&url=http://example.com
  3. The page should display the tweet text and inputs for login credentials
  4. Put in login credentials and hit the login and tweet button
  5. The page goes to https://twitter.com/intent/tweet/update and says Forbidden.

I’ve checked and verified this happens on my websites and on other major websites that have a share link.

Is there a workaround for this?


#2

Just checking, have you tried with different text/url?


#3

Yes I’ve tried with no parameters and different variations. I’ve also made sure the text of the tweet was something different than was previously tweeted.

I’ve tested and verified this happens on these physical devices: iPad 2 (v6.1.3) iPhone 4s (v6.1.3) as well as using iOS simulators on browserstack.com using iPad 3rd and iPhone 4s with iOS 6.

Thanks!


#4

Thanks for sharing all that data about the various tests you have done, this is really useful. Let me try and get hold of a iOS6 simulator and see what’s going on. I’ll report back once I dig into this.


#5

Hi,
Any news on this?

Appreciate you’re help.


#6