403:Forbidden on Net::Twitter::Lite::WithAPIv1_1


#1

since januar, 14 i get 403:Forbidden with Net::Twitter::Lite::WithAPIv1_1. I don’t see i am passing limits, nor posting message >140 characters. What other reasons could exist for 403-errors?


#2

I’m having the same problem. Started somewhat recently, within the past week or two. Today is Jan 20 2014.


#3

It’s likely due to due the API requiring SSL as of Jan 14 [1]. Net::Twitter* prints a warning and the solution for this as of Jan 16, however it does not yet default to SSL. Likely adding “ssl => 1” to your ->new() parameters will fix this.

[1] https://dev.twitter.com/discussions/24239
[2] http://search.cpan.org/~mmims/Net-Twitter-4.01002/lib/Net/Twitter.pod#TWITTER_NOW_REQUIRES_SSL


#4

@forbiddenlake - Yes, this solved the problem! Thanks so much for pointing me in the right direction.


#5

Had the same problem. Adding the “ssl => 1” fixed it.


#6

Thanks @forbiddenlake, spot on.


#7

This fix works as a MAGIC! Thank you!

After accusing Dream Host for messing up my server again I ended up here…

Thanks for saving us the headache! :slight_smile:
Or at least some of the headache as we need to update over 50 files now…

my $nt = Net::Twitter::Lite::WithAPIv1_1->new(
consumer_key => ‘################################’,
consumer_secret => ‘################################’,
access_token => ‘################################’,
access_token_secret => ‘################################’,
ssl => 1, ## enable SSL! THANK YOU @forbiddenlake Chris ##
);