403 Error when Requesting an OAuth Token from the API


#1

Hi Guys - I am trying to request an OAuth token for an app linking to our twitter account but every time I try and request the token it simply throws back a 403 error:

HTTP/1.1 403 Forbidden
content-length: 0
date: Mon, 10 Feb 2014 02:31:47 UTC
server: tfe
set-cookie: guest_id=v1%3A139199950795364216; Domain=.twitter.com; Path=/; Expires=Wed, 10-Feb-2016 02:31:47 UTC
Connection: close

My Consumer Key is cvWW5XHNRS6GXJ2CsdY3g

My Request is built like this:

$request = array(
                'uri' => array(
                    'host' => 'api.twitter.com',
                    'path' => '/oauth/request_token',
                ),
                'method' => 'POST',
                'auth' => array(
                    'method' => 'OAuth',
                    'OAuth_oauth_nonce' => "somenoncehere",
                    'oauth_callback' => $callback_url,
                    'oauth_consumer_key' => $this->consumer_key,
                    'oauth_consumer_secret' => $this->consumer_secret,
                ),
            );
            $response = $this->Oauth->request($request);

I have also tried as a GET method but this gives the same error - any advice?