400 "{"errors":[{"message":"Bad Authentication data","code":215}]}


#21

My workaround for verifying credentials is to now use the /account/settings.json method and check for a ‘screen_name’ property being returned. Otherwise, an ‘error’ property will be returned.


#22

Same problem here. What’s the status of the issue?

Edit:
Just to clarify things:
I’m using Zend Framework and it’s oauth tools - the issue appears with ZF 1.9 and 1.12. And it only appears when I’m trying to verify credentials. Everything else works fine (timelines, status updates etc.). So I assume it’s not an issue of the client library since the same Http Client with the same configuration is re-used for all those actions (timeline update, verify credentials…)


#23

I’m not sure that i have the same problem with all of you .
I got the response as following
HTTP/1.1 400 Bad Request
Content-Length:0
Connection: Close

I using socket in C++ to get the following of each user.
It was workable two weeks ago. However , i get a bad request now.

What’s wrong with my program?


#24

Yeah :smiley: i got it fixed now let me know if anybody is facing this kind of issue.


#25

I’m still facing this issue. Could you please give a hint


#26

have the same problem

{“errors”:[{“message”:“Bad Authentication data”,“code”:215}]}

curl -X GET -H “Authorization: OAuth oauth_nonce=“OAUTH_ONCE”, oauth_timestamp=“1355389805”, oauth_version=“1.0”, oauth_consumer_key=“CONSUMER_KEY”, oauth_signature=“SIGNATURE”, oauth_signature_method=“HMAC-SHA1”, oauth_callback=“rstwitterengine%3A%2F%2Fauth_token””

and it is strange, cause epochconverter.com said to me, that oauth_timestamp is NOW date


#27

I get this error for https://api.twitter.com/1.1/followers/ids.json and for https://api.twitter.com/1.1/statuses/update_with_media.json.
Workaround for both - use version 1.
https://api.twitter.com/1/followers/ids.json
https://api.twitter.com/1/statuses/update_with_media.json


#28

it looks like no one can solve the issue


#29

:frowning:


#30

I am getting error
{“errors”:[{“message”:“Bad Authentication data”,“code”:215}]}

for using this Url
https://api.twitter.com/1.1/statuses/home_timeline.json?screen_name=username

so can any one fix this bug.


#31

Are you using OAuth when you connect?

The home timeline doesn’t take a screen_name parameter. You only get the home timeline of the authenticating user.


#32

j


#33

Is this issue resolved? I tried both https://api.twitter.com/1.1/account/settings.json and https://api.twitter.com/1/account/settings.json but still returning same error message.


#34

is there any workaround on this? im using /statuses/update.json


#35

weird, I change my system to use the twitteroauth provided by abraham, then it can be used. While my original epioauth and tmhoauth cannot be used to get the credentials. The twitteroauth mentioned can be downloaded here: https://github.com/abraham/twitteroauth


#36

Hi …I am using this
$json_data = json_decode(file_get_contents(“https://api.twitter.com/1.1/statuses/retweets/283408447997886464.json”));
var_dump($json_data);

to extract the retweets of a particular status by it’s id, But I am getting the following error…

file_get_contents(https://api.twitter.com/1.1/statuses/retweets/283408447997886464.json?include_entities=true): failed to open stream: HTTP request failed! HTTP/1.0 400 Bad Request in

I am unable to figure out why this is happening, please help me…


#37

Hi,
I am using this url to fetch feeds from twitter home.
http://api.twitter.com/1/statuses/user_timeline.json?screen_name=username&page=1&count=20&include_rts=true.
I got only feeds what i post.But i need full home feeds what i posts and what my followers posts.
So can any one help and give the correct solution to fetch.What i am having feeds from my twitter home page


#38

Having the same problem. Is it solved yet?


#39

1


#40

Hi guys. I had this error response over and over again. Here is my comment about using api 1 instead of 1.1 in this thread.
But, actually it was my mistake!
I`ve always sent wrong Auth header. Actually the mistake was in time stamp. Somehow i put comma in it, so my timestamp were looking like that: timestamp:“1347058301,456” (thats the result of (DateTime.UtcNow - new DateTime(1970, 1, 1, 0, 0, 0)).TotalSeconds.ToString() in c#)
The bad thing was that such a timestamp works in my GET requests. And does not work in POST request (update_with_media).
So i fix the timestamp, and everything is working now.
Fix your mistakes guys.
Good luck.