1.1/statuses/update.json 401 error


#1

Having been through the oAuth process with HTTP_OK (200) responses and obtained a token an a secret what could cause a 401 error when trying to post a tweet ??

I’ve got the consumer key/secret and token/secret

The app is authorised with read, write and Access direct messages permissions

I’ve tried both from the account that created the app and another account that authorized the app but neither will post a tweet

please help as i’ve spent two days on this now and am stumped


#2

Note if I use the tokens in “Your access token” in my account using the same call I can post to my own timeline as me … but obliviously that does not enable the application to post on other users timeline as themselves as it circumvents the PIN login process and they are my keys anyway


#3

Anyone ? I can’t even get account/verify_credentials to return anything other than 401 ?


#4

What language and client library are you using?

You say that you can post to your timeline using the API key - but I’m confused about you saying you can’t post from the account that created or authorised the app? Can you explain more clearly?


#5

Hi

Thanks fir the reply

I’m using a language you probably won’t have heard of called Visual Dataflex and the latest Chilkat ActiveX library

Basically if I use the PIN auth sequence the token/secret I get back I cannot seem to use for anything not even verify_credentials which is odd because I’ve had http 200 codes throughout the 3leg process

If I use the api key shown under the consumer key in my account then I can post to my timeline

I’ve tried regenerating both the consumer and api keys in my account but this makes no difference

Permissions are set to read,write,direct access

Hope that is clearer ?

Thanks